package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`trans\('([a-zA-Z]+[.])+(testword|testword2|testword1|testword3)'\)`)
var str = `Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
Edit the Expression & Text to see matches. Roll over matches or the expression for details. Undo mistakes with ctrl-z. Save Favorites & Share expressions with friends or the Community. Explore your results with Tools. A full Reference & Help is available in the Library, or watch the video Tutorial.
Sample text for testing:
abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789 _+-.,!@#$%^&*();\/|<>"'
12345 -98.7 3.141 .6180 9,000 +42
555.123.4567 +1-(800)-555-2468
foo@demo.net bar.ba@test.co.uk
www.demo.com http://foo.co.uk/
http://regexr.com/foo.html?q=bar
https://mediatemple.net
trans('asd.asd.testword')
trans('asddd.asd.asd.testword1')
trans('asggfd.asd.asd.asd.asd.testword2')
trans('asdrtd.testword3')
((^|, )(part1|part2|part3))+$`
var substitution = "trans('common.$2')"
fmt.Println(re.ReplaceAllString(str, substitution))
}