package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\$(?:(?:\w+\.)+\w{2,})+(?:(?:\w+\/)+\w+)*$`)
var str = `$example.com
$example.com/invoices/12345
$bob.example.com
$example.com/bob
$ilp.uphold.com/PM3RAZfjyXWf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}