import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\$(?:(?:\\w+\\.)+\\w{2,})+(?:(?:\\w+\\/)+\\w+)*$";
final String string = "$example.com\n"
+ "$example.com/invoices/12345\n"
+ "$bob.example.com\n"
+ "$example.com/bob\n"
+ "$ilp.uphold.com/PM3RAZfjyXWf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}