re = /^\$(?:(?:\w+\.)+\w{2,})+(?:(?:\w+\/)+\w+)*$/m
str = '$example.com
$example.com/invoices/12345
$bob.example.com
$example.com/bob
$ilp.uphold.com/PM3RAZfjyXWf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end