import re
regex = re.compile(r"^\$(?:(?:\w+\.)+\w{2,})+(?:(?:\w+\/)+\w+)*$", flags=re.MULTILINE)
test_str = ("$example.com\n"
"$example.com/invoices/12345\n"
"$bob.example.com\n"
"$example.com/bob\n"
"$ilp.uphold.com/PM3RAZfjyXWf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")