$re = '/^\$(?:(?:\w+\.)+\w{2,})+(?:(?:\w+\/)+\w+)*$/m';
$str = '$example.com
$example.com/invoices/12345
$bob.example.com
$example.com/bob
$ilp.uphold.com/PM3RAZfjyXWf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);