#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!"[^"]*"(?:,"[^"]*")*,[\d\/]*$).+$"
Local $sString = ""text","text","text","text","text","text","text","text",01/01/2015" & @CRLF & _
""one","two","three","four","five","six","seven","eight",01/01/2015" & @CRLF & _
"" & @CRLF & _
"asdasdasdsad"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")