const regex = /^(?!"[^"]*"(?:,"[^"]*")*,[\d\/]*$).+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!"[^"]*"(?:,"[^"]*")*,[\\d\\\/]*$).+$', 'gmi')
const str = `"text","text","text","text","text","text","text","text",01/01/2015
"one","two","three","four","five","six","seven","eight",01/01/2015
asdasdasdsad`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}