import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\"[^\"]*\"(?:,\"[^\"]*\")*,[\\d\\/]*$).+$";
final String string = "\"text\",\"text\",\"text\",\"text\",\"text\",\"text\",\"text\",\"text\",01/01/2015\n"
+ "\"one\",\"two\",\"three\",\"four\",\"five\",\"six\",\"seven\",\"eight\",01/01/2015\n\n"
+ "asdasdasdsad";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}