using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!""[^""]*""(?:,""[^""]*"")*,[\d\/]*$).+$";
string input = @"""text"",""text"",""text"",""text"",""text"",""text"",""text"",""text"",01/01/2015
""one"",""two"",""three"",""four"",""five"",""six"",""seven"",""eight"",01/01/2015
asdasdasdsad";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}