re = /^(?!"[^"]*"(?:,"[^"]*")*,[\d\/]*$).+$/mi
str = '"text","text","text","text","text","text","text","text",01/01/2015
"one","two","three","four","five","six","seven","eight",01/01/2015
asdasdasdsad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end