package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([0-9]){2}:){3}([0-9]){2}`)
var str = `@ This file written with the Avid Caption plugin, version 1
<begin subtitles>
00:00:08:00 00:00:14:03
070
00:00:14:03 00:01:02:19
085
00:01:02:19 00:01:37:04
075
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}