# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(([0-9]){2}:){3}([0-9]){2}"
test_str = ("@ This file written with the Avid Caption plugin, version 1\n\n"
"<begin subtitles>\n"
"00:00:08:00 00:00:14:03\n"
"070\n\n"
"00:00:14:03 00:01:02:19\n"
"085\n\n"
"00:01:02:19 00:01:37:04\n"
"075\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.