const regex = new RegExp('(([0-9]){2}:){3}([0-9]){2}', 'g')
const str = `@ This file written with the Avid Caption plugin, version 1
<begin subtitles>
00:00:08:00 00:00:14:03
070
00:00:14:03 00:01:02:19
085
00:01:02:19 00:01:37:04
075
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}