use strict;
my $str = '@ This file written with the Avid Caption plugin, version 1
<begin subtitles>
00:00:08:00 00:00:14:03
070
00:00:14:03 00:01:02:19
085
00:01:02:19 00:01:37:04
075
';
my $regex = qr/(([0-9]){2}:){3}([0-9]){2}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}