import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([0-9]){2}:){3}([0-9]){2}";
final String string = "@ This file written with the Avid Caption plugin, version 1\n\n"
+ "<begin subtitles>\n"
+ "00:00:08:00 00:00:14:03\n"
+ "070\n\n"
+ "00:00:14:03 00:01:02:19\n"
+ "085\n\n"
+ "00:01:02:19 00:01:37:04\n"
+ "075\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}