using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)h, (\d+)m, (\d+)e, (\d+)w [e\-][x\-][\-\s]";
string input = @"300h, 300m, 1500e, 2000w ex-
300h, 300m, 1500e, 2000w e-
3h, 5m, 5e, 5w -x
9h, 11m, 500e, 500w --
300h, 5m, 0e, 9w ex-
hift6y
300h
300h ex-
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}