use strict;
my $str = '300h, 300m, 1500e, 2000w ex-
300h, 300m, 1500e, 2000w e-
3h, 5m, 5e, 5w -x
9h, 11m, 500e, 500w --
300h, 5m, 0e, 9w ex-
hift6y
300h
300h ex-
';
my $regex = qr/(\d+)h, (\d+)m, (\d+)e, (\d+)w [e\-][x\-][\-\s]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}