$re = '/(\d+)h, (\d+)m, (\d+)e, (\d+)w [e\-][x\-][\-\s]/';
$str = '300h, 300m, 1500e, 2000w ex-
300h, 300m, 1500e, 2000w e-
3h, 5m, 5e, 5w -x
9h, 11m, 500e, 500w --
300h, 5m, 0e, 9w ex-
hift6y
300h
300h ex-
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);