package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)h, (\d+)m, (\d+)e, (\d+)w [e\-][x\-][\-\s]`)
var str = `300h, 300m, 1500e, 2000w ex-
300h, 300m, 1500e, 2000w e-
3h, 5m, 5e, 5w -x
9h, 11m, 500e, 500w --
300h, 5m, 0e, 9w ex-
hift6y
300h
300h ex-
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}