const regex = /(\d+)h, (\d+)m, (\d+)e, (\d+)w [e\-][x\-][\-\s]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)h, (\\d+)m, (\\d+)e, (\\d+)w [e\\-][x\\-][\\-\\s]', 'g')
const str = `300h, 300m, 1500e, 2000w ex-
300h, 300m, 1500e, 2000w e-
3h, 5m, 5e, 5w -x
9h, 11m, 500e, 500w --
300h, 5m, 0e, 9w ex-
hift6y
300h
300h ex-
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}