import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)h, (\\d+)m, (\\d+)e, (\\d+)w [e\\-][x\\-][\\-\\s]";
final String string = "300h, 300m, 1500e, 2000w ex-\n\n"
+ "300h, 300m, 1500e, 2000w e-\n\n"
+ "3h, 5m, 5e, 5w -x\n\n"
+ "9h, 11m, 500e, 500w --\n\n"
+ "300h, 5m, 0e, 9w ex-\n\n"
+ "hift6y\n\n"
+ "300h\n\n"
+ "300h ex-\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}