using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\n]+\s+public function [a-z]+[(][a-zA-Z0-9=',]+[)]\n+\s+[{]\n(.+?)\n+\s+[}]";
string input = @"class T
{
public function abc(dsv)
{
sdvdsv;csdcsd
sdcsdcsdc
}
public function abc(dsv)
{
sdvdsv;csdcsd
sdcsdcsdc
}
}
";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}