$re = '/[\n]+\s+public function [a-z]+[(][a-zA-Z0-9=\',]+[)]\n+\s+[{]\n(.+?)\n+\s+[}]/s';
$str = 'class T
{
public function abc(dsv)
{
sdvdsv;csdcsd
sdcsdcsdc
}
public function abc(dsv)
{
sdvdsv;csdcsd
sdcsdcsdc
}
}
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);