import Foundation
let pattern = #"[\n]+\s+public function [a-z]+[(][a-zA-Z0-9=',]+[)]\n+\s+[{]\n(.+?)\n+\s+[}]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
class T
{
public function abc(dsv)
{
sdvdsv;csdcsd
sdcsdcsdc
}
public function abc(dsv)
{
sdvdsv;csdcsd
sdcsdcsdc
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}