import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\n]+\\s+public function [a-z]+[(][a-zA-Z0-9=',]+[)]\\n+\\s+[\\{]\\n(.+?)\\n+\\s+[\\}]";
final String string = "class T\n"
+ "{\n"
+ " public function abc(dsv)\n"
+ " {\n"
+ " sdvdsv;csdcsd\n"
+ " sdcsdcsdc\n"
+ " }\n"
+ " \n"
+ " public function abc(dsv)\n"
+ " {\n"
+ " sdvdsv;csdcsd\n"
+ " sdcsdcsdc\n"
+ " }\n"
+ "}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}