const regex = new RegExp('[\\n]+\\s+public function [a-z]+[(][a-zA-Z0-9=\\',]+[)]\\n+\\s+[{]\\n(.+?)\\n+\\s+[}]', 's')
const str = `class T
{
public function abc(dsv)
{
sdvdsv;csdcsd
sdcsdcsdc
}
public function abc(dsv)
{
sdvdsv;csdcsd
sdcsdcsdc
}
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}