# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\W_]+|\b(?:\d+|ORIGIN)\b//gm;t' <<< "ORIGIN
1 malwmrllp1 lallalwgpd paaafvnghl cgshlvealy lvcgergffy tpktrreaed
61 lqvgqvelgg gpgagslqpl alegslqkrg iveqcctsic slyqlenycn"