re = /[\W_]+|\b(?:\d+|ORIGIN)\b/m
str = 'ORIGIN
1 malwmrllp1 lallalwgpd paaafvnghl cgshlvealy lvcgergffy tpktrreaed
61 lqvgqvelgg gpgagslqpl alegslqkrg iveqcctsic slyqlenycn'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result