import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# Domain portion\n"
+ "([a-zA-Z0-9\\-\\.]+)\n\n"
+ "# Dot before the '.com', '.edu', etc.\n"
+ "\\.\n\n"
+ "# \n"
+ "(com|org|me|io|net|co|edu|uk|ca|de|jp|fr|au|us|ru|ch|it|nl|se|no|es)";
final String string = "# SHOULD MATCH:\n\n"
+ "You can visit www.google.com\n"
+ "<b>www.google.com</b>\n"
+ "<b>www.google.com</b> and www.yahoo.com\n"
+ "http://www.google.com\n"
+ "www.example.co.uk\n\n\n"
+ "# WHAT SHOULD MATCH HERE?\n\n"
+ "www.url-with-querystring.com/?url=has-querystring\n\n\n\n"
+ "# SHOULD NOT MATCH:\n\n"
+ "www..example.com\n"
+ "www.example..com\n"
+ "www.example.zz\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}