// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)# Domain portion
([a-zA-Z0-9\-\.]+)
# Dot before the '.com', '.edu', etc.
\.
#
(com|org|me|io|net|co|edu|uk|ca|de|jp|fr|au|us|ru|ch|it|nl|se|no|es)").unwrap();
let string = "# SHOULD MATCH:
You can visit www.google.com
<b>www.google.com</b>
<b>www.google.com</b> and www.yahoo.com
http://www.google.com
www.example.co.uk
# WHAT SHOULD MATCH HERE?
www.url-with-querystring.com/?url=has-querystring
# SHOULD NOT MATCH:
www..example.com
www.example..com
www.example.zz
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}