import Foundation
let pattern = ##"""
# Domain portion
([a-zA-Z0-9\-\.]+)
# Dot before the '.com', '.edu', etc.
\.
#
(com|org|me|io|net|co|edu|uk|ca|de|jp|fr|au|us|ru|ch|it|nl|se|no|es)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ##"""
# SHOULD MATCH:
You can visit www.google.com
<b>www.google.com</b>
<b>www.google.com</b> and www.yahoo.com
http://www.google.com
www.example.co.uk
# WHAT SHOULD MATCH HERE?
www.url-with-querystring.com/?url=has-querystring
# SHOULD NOT MATCH:
www..example.com
www.example..com
www.example.zz
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)