# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
# Domain portion
([a-zA-Z0-9\-\.]+)
# Dot before the '.com', '.edu', etc.
\.
#
(com|org|me|io|net|co|edu|uk|ca|de|jp|fr|au|us|ru|ch|it|nl|se|no|es)
"""
test_str = ("# SHOULD MATCH:\n\n"
"You can visit www.google.com\n"
"<b>www.google.com</b>\n"
"<b>www.google.com</b> and www.yahoo.com\n"
"http://www.google.com\n"
"www.example.co.uk\n\n\n"
"# WHAT SHOULD MATCH HERE?\n\n"
"www.url-with-querystring.com/?url=has-querystring\n\n\n\n"
"# SHOULD NOT MATCH:\n\n"
"www..example.com\n"
"www.example..com\n"
"www.example.zz\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.