re = /# Domain portion
([a-zA-Z0-9\-\.]+)
# Dot before the '.com', '.edu', etc.
\.
#
(com|org|me|io|net|co|edu|uk|ca|de|jp|fr|au|us|ru|ch|it|nl|se|no|es)/mx
str = '# SHOULD MATCH:
You can visit www.google.com
<b>www.google.com</b>
<b>www.google.com</b> and www.yahoo.com
http://www.google.com
www.example.co.uk
# WHAT SHOULD MATCH HERE?
www.url-with-querystring.com/?url=has-querystring
# SHOULD NOT MATCH:
www..example.com
www.example..com
www.example.zz
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end