use strict;
my $str = '# SHOULD MATCH:
You can visit www.google.com
<b>www.google.com</b>
<b>www.google.com</b> and www.yahoo.com
http://www.google.com
www.example.co.uk
# WHAT SHOULD MATCH HERE?
www.url-with-querystring.com/?url=has-querystring
# SHOULD NOT MATCH:
www..example.com
www.example..com
www.example.zz
';
my $regex = qr/# Domain portion
([a-zA-Z0-9\-\.]+)
# Dot before the '.com', '.edu', etc.
\.
#
(com|org|me|io|net|co|edu|uk|ca|de|jp|fr|au|us|ru|ch|it|nl|se|no|es)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}