#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![^\/$-]*[\/$-]{2})[\w\/$-]+(?<![\/-])$"
Local $sString = "String of any length that can be alphanumeric with $,-, or /, but does not match when it contains more than two of these non-alphanumeric characters in a row, or ends with / or -" & @CRLF & _
"" & @CRLF & _
"Hello/World" & @CRLF & _
"Hello//World" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")