const regex = /^(?![^\/$-]*[\/$-]{2})[\w\/$-]+(?<![\/-])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![^\\\/$-]*[\\\/$-]{2})[\\w\\\/$-]+(?<![\\\/-])$', 'gm')
const str = `String of any length that can be alphanumeric with \$,-, or /, but does not match when it contains more than two of these non-alphanumeric characters in a row, or ends with / or -
Hello/World
Hello//World
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}