import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![^\\/$-]*[\\/$-]{2})[\\w\\/$-]+(?<![\\/-])$";
final String string = "String of any length that can be alphanumeric with $,-, or /, but does not match when it contains more than two of these non-alphanumeric characters in a row, or ends with / or -\n\n"
+ "Hello/World\n"
+ "Hello//World\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}