using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![^\/$-]*[\/$-]{2})[\w\/$-]+(?<![\/-])$";
string input = @"String of any length that can be alphanumeric with $,-, or /, but does not match when it contains more than two of these non-alphanumeric characters in a row, or ends with / or -
Hello/World
Hello//World
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}