re = /^(?![^\/$-]*[\/$-]{2})[\w\/$-]+(?<![\/-])$/m
str = 'String of any length that can be alphanumeric with $,-, or /, but does not match when it contains more than two of these non-alphanumeric characters in a row, or ends with / or -
Hello/World
Hello//World
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end