# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(34)5\1//g;t' <<< "34536
34534
34567
34534"