import Foundation
let pattern = #"(34)5\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
34536
34534
34567
34534
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)