$re = '/(34)5\1/';
$str = '34536
34534
34567
34534';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;