const regex = /(34)5\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(34)5\\1', 'g')
const str = `34536
34534
34567
34534`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);