using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(34)5\1";
string substitution = @"";
string input = @"34536
34534
34567
34534";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}