#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(34)5\1"
Local $sString = "34536" & @CRLF & _
"34534" & @CRLF & _
"34567" & @CRLF & _
"34534"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)