package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?P<LongDate>(?P<Day>\d+)[\s ]+(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December)[\s ]+(?P<Year>\d{4}))`)
var str = `of 19 September 2006 in`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}