re = /(?P<LongDate>(?P<Day>\d+)[\s ]+(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December)[\s ]+(?P<Year>\d{4}))/i
str = 'of 19 September 2006 in'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end