import re
regex = re.compile(r"(?P<LongDate>(?P<Day>\d+)[\s ]+(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December)[\s ]+(?P<Year>\d{4}))", flags=re.IGNORECASE | re.UNICODE)
test_str = "of 19 September 2006 in"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")