#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""([^"]*)".*"
Local $sString = "2014-03-20 16:53:39.741 -0700 Information 638 NICOLE Client "[WebDirect]" opening a connection from "24.114.54.155 (24.114.54.155)" using "iPad Safari 7.0 [fmwebdirect]"." & @CRLF & _
"2014-03-20 16:53:39.741 -0700 Information 94 NICOLE Client "[WebDirect] (24.114.54.155) [24.114.54.155]" opening database "ProShopPartner_v1" as "[Guest]"." & @CRLF & _
"2014-03-20 16:58:45.163 -0700 Information 98 NICOLE Client "[WebDirect] (24.114.54.155) [24.114.54.155]" closing database "ProShopPartner_v1" as "[Guest]"." & @CRLF & _
"2014-03-20 16:58:45.163 -0700 Information 22 NICOLE Client "[WebDirect] (24.114.54.155) [24.114.54.155]" closing a connection."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")